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Additional resources
As part of an improvement effort, revisions of the software and hardware are periodically released. Therefore, some functions
described in this document might not be supported by all versions of the software or hardware currently in use. The product
release notes provide the most up-to-date information on product features. Contact your technical support professional if a
product does not function properly or does not function as described in this document.

Where to get help
Support, product, and licensing information can be obtained as described below.

Product information
For product and feature documentation or release notes, go to Unity Technical Documentation at: https://www.dell.com/
unitydocs.

Troubleshooting
For information about products, software updates, licensing, and service, go to Support (registration required) at: https://
www.dell.com/support. After logging in, locate the appropriate product page.

4 Additional resources

http://bit.ly/unityinfohub
http://bit.ly/unityinfohub
https://support.emc.com/products/39955
https://support.emc.com/products/39955


Requirements for deploying a UnityVSA

Topics:

• Overview of UnityVSA
• General installation requirements and considerations
• Requirements for installing a single-SP UnityVSA
• Requirements for installing UnityVSA HA
• Requirements for installing a tie breaker node

Overview of UnityVSA
UnityVSA (Virtual Storage Appliance) is a software-defined storage platform that provides users with agility and flexibility.
UnityVSA is deployed on a VMware ESXi host and is available in two editions - Professional Edition (PE) and Community Edition
(CE). Professional Edition is a licensed product available at capacity levels of 50 TB and 350 TB. Community Edition is a free
downloadable 4 TB solution that is recommended for nonproduction use.

UnityVSA HA

UnityVSA HA is an enhanced version of single-SP UnityVSA. By adding dual-SP functionality, UnityVSA HA can recover from
one SP failure, which significantly increases the applicable use case scenarios of the system. Unlike the single-SP UnityVSA,
UnityVSA HA version is only available in Professional Edition (PE). It offers the following capacity choices: 50 TB and 350 TB.

Unity Cloud Edition

Deploying Unity Cloud Edition with VMware Cloud on AWS (VMC) provides benefits to both cloud and on-premises storage
resources.

Unity Cloud Edition enables your cloud resources to use UnityVSA features and file management in the cloud storage
environment.

Data mobility between Unity Cloud Edition and on-premises Unity and UnityVSA appliances is the same as data mobility between
on-premises appliances. As a result, Unity Cloud Edition enables cloud-based data protection for block and file resources hosted
on-premises.
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Figure 1. Unity Cloud Edition integration with VMware Cloud on AWS (VMC)

Unity Cloud Edition HA can be upgraded without disrupting workloads.

This document describes how to deploy UnityVSA, UnityVSA HA, Unity Cloud Edition, Unity Cloud Edition HA, and the Tie
Breaker Node (TBN) for UnityVSA HA. For information about using UnityVSA or Unity Cloud Edition, see Dell EMC UnityVSA
Frequently Asked Questions, which is available from the UnityVSA Info Hub, and see the UnityVSA online help.

General installation requirements and considerations
These installation requirements and considerations apply to both the single-SP UnityVSA and UnityVSA HA. For requirements
specific to the single-SP models, see Requirements for installing a single-SP UnityVSA. For requirements specific to the
UnityVSA HA models, see Requirements for installing UnityVSA HA.

ESXi host requirements

A 64-bit ESXi host is required for installing UnityVSA. UnityVSA is not supported on all versions of vCenter. For more
information on supported versions, refer to the Unity Support Matrix. For UnityVSA HA, separate ESXi hosts for SPA, SPB,
and the Tie Breaker Node (TBN) are recommended. The use of vCenter to manage ESXi hosts is optional for a single-SP
deployment and mandatory for a UnityVSA HA deployment.

Although you can use nested ESXi with a single-SP UnityVSA, deployment, it is not recommended unless it guarantees the
exclusive reservation of computing and network resources. Do not use nested ESXi with a UnityVSA HA deployment, because it
does not work with HA.

UnityVSA deployment is also supported on VMware Cloud on AWS. The Community Edition and single-SP Professional Edition
can optionally be deployed on a VxRail appliance.

VM environment for on-premises deployment

The ESXi host provides the storage virtualization, which abstracts the physical storage layer from the VM. Datastores are the
logical containers that are created on physical storage. Datastores contain the virtual disks that are used by a VM to store its
operating system, program files, and other data associated with its activities. You can configure VMs with multiple virtual disks.

From the standpoint of the VM, each virtual disk looks like a SCSI drive that is connected to a SCSI controller. Whether the
actual physical storage is being accessed through local storage or network adapters on the host is typically transparent to the
VM.
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A VM is connected to a virtual network by assigning the VM's network adapters to that network's port group. A vSphere switch
detects which virtual machines are connected to each of its virtual ports and uses that information to forward traffic to the
correct VM.

For information about configuring and managing a VM environment, see the VMware vSphere documentation.

Network configuration

To deploy and configure UnityVSA, you must provide network configuration information. Contact your network administrator to
gather network settings information before you install UnityVSA.

UnityVSA can be configured to use:

● One IPv4 address (static or dynamic)
● One IPv6 address (static or dynamic)
● Both an IPv4 address and an IPv6 address

To use dynamic addressing, your network environment must include a DHCP server (DHCPv4 for an IPv4 address and DHCPv6
or SLAAC for an IPv6 address). If the network environment is not dynamic, you must assign the management IP address
manually.

If UnityVSA is configured with a single IP address, a DNS server is optional but highly recommended. If UnityVSA is configured
with both an IPv4 and IPv6 address, a DNS configuration is required.

Heartbeat mechanism requirements

UnityVSA HA and the TBN use Layer 2 Ethernet broadcasts to monitor the heartbeats of connected systems. For UnityVSA HA
and the TBN to function, each heartbeat network (HB0 and HB1) must reside on the same Layer 2 broadcast domain and VLAN
and have Layer 2 broadcast traffic enabled.

Considerations for server hardware platforms that do not support CPU
instruction set SSE 4.2

Starting in the UnityVSA 4.3 release, server hardware platforms that do not support CPU instruction set SSE 4.2 are no longer
supported. You might encounter an error that prevents you from deploying your new 4.3 or later OVA under the following
circumstances:

● You are running in an ESXi cluster environment.
● The Enhanced vMotion Compatibility (EVC) settings are set to strict.
● There is a nonsupported server in your cluster.

This error can occur even if the server on which you intend to install the UnityVSA supports SSE 4.2. If you deploy a 4.3 or
later UnityVSA on a single server and receive this error, choose a newer server platform on which to run ESXi. If you deploy
or upgrade a previously running 4.0, 4.1, or 4.2 version of UnityVSA within an ESXi cluster, update your EVC settings so that
the UnityVSA can only run on the servers in the cluster whose CPUs support SSE 4.2. Otherwise, you must remove the older,
nonsupported servers from your cluster environment.

For instructions on modifying the EVC setting within an ESXi cluster, see the VMware documentation.

NOTE: Changes to your EVC control require you to power cycle UnityVSA within VMWare. A shutdown, restart, or a reboot

of UnityVSA is not sufficient to correct this issue after modifying the EVC settings. Power cycling a UnityVSA is a disruptive

operation that should be scheduled in advance.

Requirements for installing a single-SP UnityVSA
Dell EMC UnityVSA single-SP can run on any server that supports VMware ESXi and meets the minimum requirements. If
local storage is used, a hardware RAID controller on the ESXi host must be used to configure redundant storage for Dell EMC
UnityVSA single-SP. If storage is being provided from a redundant storage system or server SAN, a RAID controller on the ESXi
host is not required.

NOTE: The UnityVSA SP requirements refer to the UnityVSA VM settings.
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Table 1. Server and VM requirements 

Minimum requirement Recommended requirement

ESXi requirements

ESXi host configuration ESXi 6.5 or later ESXi 6.5 or later

Hardware processor Xeon E5 Series Dual Core
CPU 64-bit x86 Intel
2GHz+ (SSE4.2 or later)

Xeon Silver 4110 or higher

Hardware memory 20 GB minimum for ESXi
6.5 or later

36 GB minimum for ESXi 6.5 or later

Hardware network 1x 1 GbE (management and
IO traffic go through the
same physical port)

1x 10 GbE (management and IO
traffic go through the same physical
port)

Hardware RAID RAID Controller: 512 MB
NV cache and battery
backed recommended

RAID Controller: 512 MB NV cache
and battery backed recommended

Disk Any disk type as system
disks

SSD as system disks

Datastore requirements

VMware datastore (NFS and VMFS supported) No particular requirement Full-SSD datastore

UnityVSA SP requirements

Virtual processor cores 2 (2 GHz+) 2 (2 GHz+)

Virtual system memory 12 GB 12 GB

Virtual network adapters 6 (4 adapters for I/O, 1 for
Unisphere, and 1 for system
use)

6 (4 adapters for I/O, 1 for
Unisphere, and 1 for system use)

Requirements for installing UnityVSA HA
Installing and configuring a UnityVSA HA requires a 64-bit ESXi host running version 6.5 or later and a VMware vSphere
Enterprise Plus license. The use of vCenter to manage ESXi hosts is mandatory. The hosts should have two unused vmnic ports
per ESXi host (if deploying on two different hosts and no existing distributed switch).

When adding new virtual disks, there are special considerations depending on the sharing mode of the VM's SCSi controller. For
more information, see Add virtual disks to a UnityVSA HA deployment.

Ensure that you deploy each UnityVSA HA SP on a separate ESXi host. Single ESXi host configurations are not supported.

Table 2. Server and VM requirements 

2-core Unity VSA 12-core Unity VSA

ESXi requirements

ESXi host configuration ESXi 6.5 or later with both
SPs on separate ESXi hosts

ESXi 6.5 or later with both SPs on
separate ESXi hosts

Hardware processor Xeon Silver 4110 or higher Xeon Silver 4110 or higher

Hardware memory 36 GB for ESXi 6.5 or later
per host

120 GB for ESXi 6.5 or later per host

Hardware network 3 x 10 GbE (1 physical
port for SP management
and IO ports, 2 for inter-SP
network)

3 x 10 GbE (1 physical port for
SP management and IO ports, 2 for
inter-SP network)
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Table 2. Server and VM requirements (continued)

2-core Unity VSA 12-core Unity VSA

Hardware RAID RAID card 512 MB NV
cache, battery backed
recommended

RAID card 512 MB NV cache, battery
backed recommended

Disk No particular requirement SSD as system disks

Switch requirements

Hardware switch 10Gb port support 10Gb port support

Datastore requirements

VMware datastores (NFS and VMFS supported) One full-SSD shared
datastore and a separate
full-SSD local swap
datastore

One full-SSD shared datastore and
a separate full-SSD local swap
datastore

UnityVSA SP requirements

Virtual processor cores 2 (2 GHz+) for each SP 12 (2 GHz+) for each SP

Virtual system memory 12 GB for each SP 96 GB for each SP

Virtual network adapters 9 for each SP (4 ports
for I/O, 1 for Unisphere, 1
for system use, and 3 for
internal communication)

9 for each SP (4 ports for I/O, 1 for
Unisphere, 1 for system use, and 3
for internal communication)

vCenter Required Required

VLANs 3 (1 for Common
Messaging Interface (CMI)
SP-to-SP communication, 1
for Heartbeat 0, and 1 for
Heartbeat 1).

The VLANs must be unique
and not used elsewhere on
the network.

3 (1 for Common Messaging Interface
(CMI) SP-to-SP communication, 1 for
Heartbeat 0, and 1 for Heartbeat 1).

The VLANs must be unique and not
used elsewhere on the network.

Requirements for installing a tie breaker node
Installing a Tie Breaker Node (TBN) on UnityVSA HA requires a host with at least:

● 2 GB memory
● 500 MHz x 2 cores CPU
● 12 GB disk space
● 2x1 GbE for the network with UnityVSA HA

NOTE: These requirements are in addition to those required by UnityVSA HA.

It is recommended that you deploy the TBN VM on a third ESXi host; that is, a host that is not supporting the UnityVSA SPs.

Requirements for deploying a UnityVSA 9



Deploying a single-SP UnityVSA

Topics:

• Set up the VM environment for a single-SP UnityVSA
• Download the OVA file for a single-SP UnityVSA
• Deploy a single-SP UnityVSA directly to an ESXi host
• Deploy a single-SP UnityVSA through a vCenter server
• Add virtual disks to a single-SP UnityVSA deployment

Set up the VM environment for a single-SP UnityVSA

Steps

1. Verify that the selected ESXi host meets the required configuration, as outlined in Requirements for installing a single-SP
UnityVSA.

2. Verify, and if necessary configure, the host network configuration.

3. Verify that a vSphere switch has been created.

a. Determine which port groups are associated with which subnets so you can ensure that the VM's network adapters are
assigned to the correct subnet.

● Ethernet port 0 is associated with network adapter 3.
● Ethernet port 1 is associated with network adapter 4.
● Ethernet port 2 is associated with network adapter 5.
● Ethernet port 3 is associated with network adapter 6.

You can verify which VM network adapter is mapped to which UnityVSA Ethernet port by comparing the MAC address
displayed for the network adapter in the vSphere VM Hardware summary to the MAC address displayed for the Ethernet
port in Unisphere.

To display the MAC address in Unisphere, select System > System View > Enclosures. Select the rear view of the Disk
Processor Enclosure (DPE) and click on an Ethernet port to display detailed information about the port, including its MAC
address. It is important to take note of the Ethernet port name, for example, SPA Ethernet Port 3, since this is the port
name used when creating iSCSI and replication network interfaces.

b. If the network environment supports jumbo frames, verify that the MTU value for the switch on the ESXi host is set to
the same value as the UnityVSA Ethernet ports.

If the UnityVSA VM sets an MTU value that is higher than the MTU value set on ESXi, the UnityVSA VM MTU value
defaults to the smaller value. In vSphere, select Edit Settings on the Virtual switch to check the MTU value.

In Unisphere, select the Settings icon, and then select Access > Ethernet. MTU is not displayed by default so you must
select the Customize icon, select Columns and then click on MTU.

The VMware Knowledge Base article, iSCSI and Jumbo Frames configuration on VMware ESXi/ESX (1007654), provides
more information.

NOTE: Do not make any changes to the VM, such as changing the virtual hardware configuration (CPU, memory, NICs,

and so on), as this causes UnityVSA to boot in service mode in order to prevent invalid configurations.

2
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Download the OVA file for a single-SP UnityVSA

Prerequisites

To download the UnityVSA Professional Edition, you must set up a product support account. If you do not already have
an account, go to your product support site to set one up. To download the UnityVSA Community Edition, go to the EMC
Community Network website.

Steps

1. Using a web browser, go to your product support or community site.

2. Select UnityVSA.

3. Locate the available downloads.

4. Select the UnityVSA Open Virtualization Appliance (OVA) file.

5. Save the OVA file to your computer.

Deploy a single-SP UnityVSA directly to an ESXi host

Steps

1. Access the ESXi server by using its IP address.

2. Select Virtual Machines > Create / Register VM to launch the wizard. Using the wizard, complete the following steps.

3. Select Deploy a virtual machine from an OVF or OVA file.

4. Enter a name for the new VM and select the OVA file to deploy.

5. Verify the OVF template details, including that the OVA image is signed by Dell EMC.

6. Select a datastore from the list of datastores accessible from the resource you selected in which to create the virtual disks
used to store the VM configuration files.

For optimal performance, if you are not deploying UnityVSA on a VxRail appliance, deploy the UnityVSA VM on a datastore
comprised of different physical disks than the datastore that will contain the virtual disks that provide user data storage to
UnityVSA. Failure to follow this recommendation can lead to system and I/O performance degradation. If you are deploying
UnityVSA on a VxRail appliance, vSAN selects the physical disks.

7. Select the network mapping, disk provision type, and power on option for the VM.

8. Enter the system name and configure the management IP (IPv4 or IPv6).

9. Review the deployment settings and finish the wizard.

10. Select the UnityVSA VM. Select the Summary tab to view information about the VM.

11. To determine when the UnityVSA VM is fully up and running, monitor the DNS Name field on the Summary tab. When the
DNS Name field displays a system name, the UnityVSA VM is ready.

NOTE: The system name displayed is either the name you specified during deployment or the serial number of the

system (format is VIRTXXXXXXXXXX).

12. If you are running the UnityVSA VM on a dynamic network using DHCP or SLAAC, the management IP address is assigned
automatically.

You can find the assigned IP by logging into the UnityVSA.

13. If you are not running the UnityVSA VM on a dynamic network using DHCP or SLAAC and you did not configure the
management interface when you deployed the OVF template, you must do the following:

a. Open the vSphere Console.
b. Log in using the service account username and password service/service
c. Run the svc_initial_config command to assign an IP address.

For an IPv4 address, enter:

svc_initial_config -4 "<ipv4_address> <ipv4_netmask> <ipv4_gateway>"
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For an IPv6 address, enter:

svc_initial_config -6 "<ipv6_address> <ipv6_prefix_length> <ipv6_default_gateway>"

For full usage, enter:

svc_initial_config -h 
          

NOTE: Alternatively, you can run the svc_diag command from the vSphere Console and identify the UnityVSA system

serial number from the output. Then you can use the Connection Utility to discover a list of systems, find the UnityVSA

serial number in the list, and assign an IP address.

14. Enter the UnityVSA management IP address in your browser to open Unisphere.

Deploy a single-SP UnityVSA through a vCenter
server

Steps

1. Access vCenter using this URL: https://<vCenter_address>/ui.

2. Select the host, select Actions and select Deploy OVF template to launch the Deploy OVF Template wizard. Using the
wizard, complete the following steps.

3. To select the source from which to deploy, select Local File and then click the Choose Files.

4. Select a folder or datacenter location for the new VM.

5. Optionally, change the compute resource to a different host. By default, the host on which you invoked the wizard is
selected.

6. Verify the OVF template details, including that the OVA image is signed by Dell EMC.

7. Select a datastore from the list of datastores accessible from the resource you selected in which to create the virtual disks
used to store the VM configuration files.

For optimal performance, if you are not deploying UnityVSA on a VxRail appliance, deploy the UnityVSA VM on a datastore
comprised of different physical disks than the datastore that will contain the virtual disks that provide user data storage to
UnityVSA. Failure to follow this recommendation can lead to system and I/O performance degradation. If you are deploying
UnityVSA on a VxRail appliance, vSAN selects the physical disks.

8. Select a disk format for provisioning the VM's virtual disks.

NOTE: For better performance, it is recommended that you select Thick Provision Eager Zeroed.

9. Select a VM storage policy, if applicable.

10. Configure the networks the deployed VM should use, making sure that:

● The management network is on a network accessible by the workstation used to access Unisphere.
● The data networks are on networks accessible by the host that will attach to the UnityVSA.

NOTE: If you are deploying the UnityVSA on a VxRail appliance, it is recommended that you deploy the UnityVSA on the

same port group used by the client VMs that reside on the VxRail appliance.

11. Customize the settings for the UnityVSA VM, including the system name and the network:

a. Enter a user friendly name for the UnityVSA. Leave this field blank to use the default name: an automatically generated
serial number for UnityVSA.

b. If you want to use static IP addresses, enter the IPv4 and IPv6 management settings.
c. If you want to use dynamic IP addresses, leave these fields blank for automatic configuration using DHCP.
d. If you do not have a dynamic network and you do not specify a static IP address, you must specify the IP address after

the OVF template is deployed.

12. Confirm the settings, and then click Finish to deploy the OVF template.

13. Select the UnityVSA VM. Select the Summary tab to view information about the VM. If it is not already powered on, select
Power On to start the VM.
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14. To determine when the UnityVSA VM is fully up and running log in to UnityVSA to check.

NOTE: The system name displayed is either the name you specified during deployment or the serial number of the

system (format is VIRTXXXXXXXXXX).

15. If you are not running the UnityVSA VM on a dynamic network using DHCP or SLAAC and you did not configure the
management interface when you deployed the OVF template, you must open the vSphere Console and login using the
service account service/service and run the svc_initial_config command to assign an IP address.

For an IPv4 address, enter:

svc_initial_config -4 "<ipv4_address> <ipv4_netmask> <ipv4_gateway>"

For an IPv6 address, enter:

svc_initial_config -6 "<ipv6_address> <ipv6_prefix_length> <ipv6_default_gateway>"

For full usage, enter:

svc_initial_config -h 
          

NOTE: Alternatively, you can run the svc_diag command from the vSphere Console and, from the output, identify the

UnityVSA system serial number. Then use the EMC Connection Utility to discover a list of systems, find the UnityVSA

serial number in the list, and assign an IP address.

16. Enter the UnityVSA management IP address in your browser to open Unisphere.

Add virtual disks to a single-SP UnityVSA deployment

About this task

When you create the UnityVSA VM, three virtual disks (vmdks) are automatically created for the VM's system data. These are
the virtual disks identified as 1-3. Do not modify or delete these disks.

You must add at least one virtual disk for user data. You can add more virtual disks, up to the system limit (16), when additional
storage for user data is needed. The minimum virtual disk size is 10 GB. A disk appears as faulted if it is smaller than 10 GB and
larger than the storage size allowed by the UnityVSA edition and version. To view your system's limits, in Unisphere select the
Settings icon, and then select Software and Licenses > System Limits

The following considerations apply to virtual disks in a single-SP UnityVSA deployment:

● For optimal performance, it is recommended that you create the virtual disks used to provide user data on a different
datastore than the one where UnityVSA is deployed. Failure to follow this recommendation can lead to system and I/O
performance degradation.

● You can only connect 12 virtual disks for user data to the first VMware paravirtual SCSI controller provided with the
UnityVSA. If you add a 13th virtual disk, select the second controller. Make sure this controller is of type VMware
paravirtual. If the SCSI controller is a different type, UnityVSA can have boot problems and can fail to recognize the
new virtual disks attached to it.

● Allow up to 60 seconds for UnityVSA to recognize and display the newly attached virtual disks.
● Using vSphere to modify the physical configuration of a UnityVSA VM (such as adding or removing network interfaces or

modifying the VM's cache size) is not supported, except for adding virtual disks to store user data.

Steps

1. In vSphere, right-click on the UnityVSA SPA VM, and select Edit > Settings.

2. On the Virtual Hardware tab, select Add New Device > Hard Disk.

3. Enter the size and provisioning method of the disk you want to add.

4. Finish stepping through the wizard, and select Finish.
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Next steps

NOTE: Resizing a virtual disk through VMware is not supported in UnityVSA. However, if the virtual disk is not part of

a storage pool, you can remove it from UnityVSA and add a new one of the preferred size. Resizing virtual disks that are

already part of a storage pool can result in a failed, unrecoverable pool.

14 Deploying a single-SP UnityVSA



Deploying UnityVSA HA

Topics:

• Set up the VM environment for UnityVSA HA
• Download the UnityVSA HA files
• Deploy UnityVSA HA on an on-premises ESXi host with the UnityVSA Deployment Utility
• Deploy Unity Cloud Edition with the UnityVSA Deployment Utility
• Deploy a UnityVSA HA on an on-premises ESXi host using the UnityVSA HA Deployment Utility CLI
• Manage virtual disks for Unity Cloud Edition
• Add virtual disks to a UnityVSA HA deployment

Set up the VM environment for UnityVSA HA

Steps

1. Log into vCenter as a user with administrative privileges.

2. Verify that the selected ESXi host meets the required configuration, as outlined in Requirements for installing UnityVSA HA.

3. (On-premises only) Verify, and if necessary, configure the host network configuration.

4. Check whether there are three available, unused VLANs in the network environment to use for deploying the CMI, HB0, and
HB1 networks.

NOTE: Dual-SP Unity VSA configurations use private VLANs that are created in vSphere when the appliance is installed.

Do not use these private port groups and private VLAN IDs, which could interfere with UnityVSA.

5. (Unity Cloud Edition only) If you are deploying to VMC, verify that four network segments have been created.

Three network segments are for deploying the CMI, HB0, and HB1 networks. One network segment is for I/O.

6. (Optional, on-premises only) Verify that a vSphere switch has been created.

You can create a switch later using the Deployment Utility. If you choose to create a switch before deployment, observe the
following guidelines:

a. Determine which port groups are associated with which subnets so you can ensure that the VM's network adapters are
assigned to the correct subnet.

● Ethernet port 0 is associated with network adapter 6.
● Ethernet port 1 is associated with network adapter 7.
● Ethernet port 2 is associated with network adapter 8.
● Ethernet port 3 is associated with network adapter 9.

To verify which VM network adapter is mapped to which UnityVSA Ethernet port, compare the MAC address for the
network adapter in the vSphere VM Hardware summary to the MAC address for the Ethernet port in Unisphere.

To display the MAC address in Unisphere, select System > System View > Enclosures. Select the rear view of the Disk
Processor Enclosure (DPE) and click an Ethernet port to display information about the port, including its MAC address.
Take note of the Ethernet port name, for example, SPA Ethernet Port 3, since the port name is used when creating
iSCSI and replication network interfaces.

b. If the network environment supports jumbo frames, verify that the MTU value for the switch on the ESXi host is set to
the same value as the UnityVSA Ethernet ports.

If the UnityVSA VM sets an MTU value higher than the MTU value set on ESXi, the UnityVSA VM MTU value defaults to
the smaller value. In vSphere, select Edit Settings on the Virtual switch to check the MTU value.

In Unisphere, select the Settings icon, and then select Access > Ethernet. MTU is not displayed by default so you must
select the Customize icon, select Columns, and then click MTU.

3
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The VMware Knowledge Base article iSCSI and Jumbo Frames configuration on VMware ESXi/ESX (1007654) provides
more information.

NOTE: Do not modify the VM, such as changing the virtual hardware configuration (CPU, memory, NICs, and so on).

Modifying the VM causes UnityVSA to boot in service mode to prevent invalid configurations.

Download the UnityVSA HA files

Prerequisites

To obtain a UnityVSA Professional Edition license and download UnityVSA HA files, you must set up a product support account.
If you do not already have an account, go to your product support site to set one up.

Steps

1. Using a web browser, go to your product support site.

The files for Unity Cloud Edition are available from the VMware Cloud Marketplace website.

2. Select UnityVSA.

3. Locate the available downloads.

4. Select each of these files and save them to your computer: UnityVSA OVA file, TBN OVA file (as necessary), and the
UnityVSA HA Deployment Utility.

Deploy UnityVSA HA on an on-premises ESXi host
with the UnityVSA Deployment Utility

Prerequisites

1. Follow the directions for setting up the VM environment in Set up the VM environment for UnityVSA HA.
2. Install and launch the UnityVSA Deployment Utility.
3. Select Deployment Utility for UnityVSA in On-premise VMware Data Center.

About this task

When you deploy UnityVSA HA on an EXSi host, you can choose whether to deploy with or without a Tie Breaker Node (TBN). A
TBN provides increased protection from network failures, because it resolves situations where one SP cannot detect the other
SP. For UnityVSA HA, the TBN is a minimal VM running a network heartbeat client, which exchanges heartbeat messages with
both SPA and SPB.

Steps

1. Select whether to deploy the new UnityVSA with or without a TBN. If you choose not to deploy the new UnityVSA with
a TBN now, you can add a TBN to the UnityVSA after it is created. For information, see Deploy a tie breaker node to an
existing UnityVSA HA using the GUI.

2. Provide the login credentials and IP details for the vCenter service. When you deploy UnityVSA with HA, the hosts must be
managed under the same vCenter datacenter.

3. Select the UnityVSA OVA file to use for the deployment.

4. Select the desired virtual hardware configuration.

5. Select a separate ESXi host for each SP deployment. For high availability reasons, do not deploy both SPs to a single ESXi
host.

6. On the System Datastores page:

● Select two datastores - one datastore for each SP - to create its private system drive. Each SP needs at least 60 GB
space for private system data.

● Select one shared datastore for a shared system drive between both SPs. The shared datastore needs at least 40 GB
free space.

NOTE: It is a best practice to select three different datastores in this step.
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7. Select two other shared datastores for storage-based heartbeats between the two SPs.

NOTE: The virtual disks that are created from the heartbeat datastores are only 2 MB in size.

8. Select the network mappings for the management and data networks, making sure that:

● The management network is on a network accessible by the workstation that is used to access Unisphere.
● The data networks are on networks accessible by the host that will attach to the UnityVSA.

9. Configure the internal network. To deploy UnityVSA HA, both SPs must communicate over a distributed switch. You can
either create a switch, or select an existing one:

● If creating a switch, you must provide two uplink ports for each ESXi host for redundancy. Each uplink port should also
connect to a different network infrastructure switch. Enter unique VLAN IDs for the HB0, HB1, and CMI networks.

● If selecting an existing switch, each ESXi host must provide for two uplink ports for redundancy. Enter unique VLAN IDs
for the HB0, HB1, and CMI networks.

Whether you use an existing switch or create one, three port groups are created, which are for HB0 (Heartbeat 0), HB1
(Heartbeat 1), and the Common Messaging Interface (CMI). Each of them requires a nonzero, unique VLAN ID. If you leave
the VLAN input empty, the deployment utility automatically chooses an unused VLAN ID for each port group.

If you deploy the SPs on different ESXi hosts, the physical switches must support VLAN and be configured as trunking mode
instead of access mode. Access mode enables only specific VLANs to pass.

10. Enter the UnityVSA system name and IP address information.

11. (Applies to deploying UnityVSA HA with a TBN) On the Configure Tie Breaker Node Properties page, enter the name of
the TBN VM, and then select the OVA file, host, and datastore to use for the TBN. You must also select two ports for the
TBN.

NOTE: It is a best practice to select a host for the TBN that has not been used for other purposes. It is also

recommended that you choose two separate ports for the TBN.

12. Review the settings, and select Deploy.

13. If you deployed the UnityVSA HA with a TBN, use Unisphere to enable the TBN function. You can do this in the Initial
Configuration Wizard or by accessing the Tie Breaker Node page in the Management settings. For information, see Enable
or change the tie breaker node on a UnityVSA HA.

Deploy Unity Cloud Edition with the UnityVSA
Deployment Utility

Prerequisites

1. Obtain the template file for your deployment type and upload it to the VMC content library. You can also add the template
file directly to your VMC content library from the VMware Cloud Marketplace website.

2. Verify that at least four network segments have been created. Three network segments are for deploying the CMI, HB0, and
HB1 networks. One network segment is for I/O.

3. Install and launch the UnityVSA Deployment Utility.
4. Select Deployment Utility for UnityVSA in VMware Cloud for AWS.

About this task

The deployment process for Unity Cloud Edition differs from the deployment process for on-premises ESXi servers.

Steps

1. Provide the login credentials and FQDN for the vCenter service.

NOTE: When you deploy Unity Cloud Edition HA, the hosts are managed under the same vCenter datacenter.

2. Select the cluster on which to deploy Unity Cloud Edition.

3. Select the Unity Cloud Edition template that you uploaded to the library and model type to use for the deployment.

4. Configure the external network mappings for the management and data networks, making sure that:

● The management network is on a network accessible by the workstation that is used to access Unisphere.
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● The data networks are on networks accessible by the host that will attach to the Unity Cloud Edition.
● The user account that you are using has Network.Assign privileges on the selected network segment.

5. Configure the internal network mappings for Common Messaging Interface (CMI) and network-based heartbeat connections.

● The internal network mappings cannot use the same network segments as the external network.
● Each of the three mappings must be unique.
● The mappings cannot be in use by another VM.
● The user account that you are using should have Network.Assign privileges on the selected network segment.

6. Enter the Unity Cloud Edition system name and management IP address.

7. Review the settings and click Deploy.

Next steps

NOTE: To guarantee HA capability, the SPA and SPB VMs must remain on separate hosts. To keep the VMs separated, you

must create an anti-affinity policy in the VMC GUI.

1. Log in to the VMC GUI.

2. Create a VM-VM anti-affinity policy that separates the two SP VMs. For more information about creating a VM-VM

anti-affinity policy, see VMware documentation.

3. If the SP VMs are powered off, power them on.

4. Ensure the two SP VMs move to separate hosts before you start provisioning.

Deploy a UnityVSA HA on an on-premises ESXi host
using the UnityVSA HA Deployment Utility CLI
You can deploy a UnityVSA HA using the UnityVSA HA Deployment Utility CLI instead of the GUI. To access the CLI:

1. Follow the directions for setting up the VM environment in Set up the VM environment for UnityVSA HA.
2. Download the UnityVSA HA Deployment Utility CLI from your support website.
3. Perform the following based on your operating system:

● On Windows, double-click the installer executable and follow the prompts. The default installation location is as follows:
○ For the x86-64 package, C:\Program Files\EMC\UnityVSA Deploy Utility CLI.

○ For the i586 package, C:\Program Files (x86)\EMC\UnityVSA Deploy Utility CLI.

● On Linux, type: rpm -ihv <filename>, where filename is the name of the installer executable. The default installation
location is:

/opt/EMC/UnityVSADeployUtilityCLI/
4. To launch the UnityVSA client and see the options and examples, perform the following in a command prompt based on your

operating system:
● From a Windows operating system, type:

UnityVSADeployUtilityCLI-<arch>-<version>.exe --h

where <version> is the version of the client installed.

● From a Unix operating system, type:

UnityVSADeployUtilityCLI --h 

Manage virtual disks for Unity Cloud Edition

Prerequisites

1. Install and launch the UnityVSA Deployment Utility.
2. Select UnityVSA Disk Management Utility.
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About this task

Unity Cloud Edition HA requires the SPA and SPB VMs to connect to and share each disk file. To share a disk file in VMware,
you must provision it as a thick eager zeroed disk.

The VMC GUI does not support provisioning thick eager zeroed disks. The UnityVSA Disk Management Utility provides a
graphical interface to add and manage disks for Unity Cloud Edition HA without requiring the SDK or PowerCLI.

Steps

1. Provide the vCenter FQDN and login credentials.

2. Select the Unity Cloud Edition HA for which you want to manage storage.

NOTE: The first five disks on the Unity Cloud Edition are system disks and are not listed in the Manage Disk table.

3. Choose the management action that you want to perform:
● To add a disk, choose the size of the disk and then click Add.
● To fix a disk that is not connected to both SPs, select the disk and click Fix Disconnected Disks.

A disk file that is not attached to both SPs is marked with a red X icon.

4. When you have finished managing your disks, close the Disk Management Utility.

Add virtual disks to a UnityVSA HA deployment

About this task

When you create the UnityVSA VM, five virtual disks (vmdks) are automatically created for the VM's system data. These are the
virtual disks identified as 1-5. Do not modify or delete these disks.

You must add at least one virtual disk for user data. You can add more virtual disks, up to the system limit (16), when additional
storage for user data is needed. The minimum virtual disk size is 10 GB. A disk appears as faulted if it is smaller than 10 GB and
larger than the storage size allowed by the UnityVSA edition and version. To view your system's limits, in Unisphere select the
Settings icon, and then select Software and Licenses > System Limits.

The following considerations apply to virtual disks in a UnityVSA HA deployment:

● For optimal performance, it is recommended that you create the virtual disks used to provide user data on a different
datastore than the one where UnityVSA is deployed. Failure to follow this recommendation can lead to system and I/O
performance degradation.

● When adding a virtual disk, you must add it to both SPA and SPB.
● You can only connect ten virtual disks for user data to the first VMware paravirtual SCSI controller provided with the

UnityVSA. If you add an 11th virtual disk, select the second controller. Make sure this controller is of type VMware
paravirtual. If the SCSI controller is a different type, UnityVSA can have boot problems and can fail to recognize the new
virtual disks attached to it.

● Allow up to 60 seconds for UnityVSA to recognize and display the newly attached virtual disks.
● Using vSphere to modify the physical configuration of a UnityVSA VM, such as adding or removing network interfaces or

modifying the VM's cache size, is not supported, except for adding virtual disks to store user data.
● Although resizing a virtual disk through VMware is not supported in UnityVSA, if the virtual disk is not part of a storage pool,

you can remove it from UnityVSA and add a new one of the preferred size. Resizing virtual disks that are already part of a
storage pool can result in a failed, unrecoverable pool.

● Important: Never add a virtual disk to an SP VM that already has a disk with the same UUID. This can happen when a
virtual disk has been added to a SP VM, then added again. Adding a disk twice can cause issues such as SP panic and data
unavailability.

● You cannot add virtual disks for use by UnityVSA to NFS datastores.

Steps

1. In vSphere, right-click on the UnityVSA SPA VM, and select Edit > Settings.

2. In the New Device field on the Virtual Hardware tab, select Add New Device, and then select Hard Disk.

3. Enter the size of the disk you want to add, and select Thick Provision Eager Zeroed as the provisioning method.

4. Depending on the sharing mode of the VM's SCSi controller, configure the disks as follows:

a. If the sharing mode is set to None:

● In Sharing, select Multi-Writer.
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● In Disk Mode, select Independent - Persistent.

b. Otherwise:

● In Sharing, select No Sharing.
● In Disk Mode, select Independent - Persistent.

5. Complete the wizard, and select Finish.

6. When the disk creation process completes, return to the home page.

7. Right-click on the UnityVSA SPB VM, and select Edit > Settings

8. On the Virtual Hardware tab, select Add New Device > Existing Hard Disk.

9. Select the existing vmdk file created in the previous steps. Depending on the sharing mode of the VM's SCSi controller,
configure the disks as follows:

a. If the sharing mode is set to None:

● In Sharing, select Multi-Writer.
● In Disk Mode, select Independent - Persistent.

b. Otherwise:

● In Sharing, select No Sharing.
● In Disk Mode, select Independent - Persistent.
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Deploying a tie breaker node to an existing
UnityVSA HA

Topics:

• Deploy a tie breaker node to an existing UnityVSA HA using the GUI
• Deploy a tie breaker node to an existing UnityVSA HA using the CLI

Deploy a tie breaker node to an existing UnityVSA HA
using the GUI

Steps

1. Launch the UnityVSA HA Deployment Utility, and select Deploy a new Tie Breaker Node to an existing Dual-SP
UnityVSA deployment.

2. Provide the IP address and login credentials for the vCenter service.
The deployment utility automatically discovers the UnityVSA HA managed by the specified vCenter.

3. Select the UnityVSA for which to deploy a Tie Breaker Node (TBN).

4. Enter the name of the TBN VM, and then select the template, host, and datastore to use for the TBN.

5. Review your choices and click Deploy.

Deploy a tie breaker node to an existing UnityVSA HA
using the CLI
You can deploy a tie breaker node to an existing UnityVSA HA using the deployment tool CLI instead of the GUI.

Format

UnityVSADeployUtilityCLI --hypervisor <value> --username <value> 
--password value --tbnfile value --tbnname <value> --hosttbn value 
---datastoreprivatetbn value --hb0net value --hb1net value

Action qualifiers

Qualifier Description

--hypervisor IP address or hostname of the vCenter service.

--username Username used to log in to the vCenter service.

--password Password used to log in to the vCenter service.

--file Path to the OVA or OVF file to deploy.

--tbnfile Path to the TBN file to deploy.

--tbnname Name of the TBN file to deploy.

4
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Qualifier Description

--hosttbn Host on which to deploy the TBN.

--datastoreprivatetbn Datastore that the TBN will reside on. The SPA and SPB hosts must be able
to access this datastore.

--hb0net Heartbeat 0 port group to which the TBN will connect.

--hb1net Heartbeat 1 port group to which the TBN will connect.

Deploying a TBN on an existing UnityVSA HA using an existing switch

The following example deploys a TBN called tbn1 on an existing UnityVSA:

UnityVSADeployUtilityCLI 
--hypervisor 10.244.236.244 
--username admin 
--password admin123 
--file unityvsa/tbn.ova 
--tbnfile tbn1
--tbnname vvnx-dual-test 
--hostspa vvnx-esx1.usd.lab.emc.com 
--hostspb vvnx-esx3.usd.lab.emc.com 
--hosttbn vvnx-esx1.usd.lab.emc.com 
--datastoreprivatespa datastore3_esx1 
--datastoreprivatespb datastore3_esx3 
--datastoreshared obsim_nfs_ds 
--datastoreprivatetbn datastore3_esx1 
--hb0net vsa-hb0-pg
--hb1net vsa-hb1-pg
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Configuring UnityVSA in Unisphere

Topics:

• Launch UnityVSA Unisphere
• Configure UnityVSA in Unisphere
• Enable or change the tie breaker node on a UnityVSA HA
• Upgrade tie breaker node after a non-disruptive upgrade

Launch UnityVSA Unisphere

Steps

1. Launch Unisphere. To do so, enter the management IP address in your browser.

2. Log in with the default username and password.

NOTE: UnityVSA ships with a default username, admin, and password. You must change the administrator password

during this first login. You can also change the service password at this time, either making it the same as the

administrator password or creating a separate service password.

Configure UnityVSA in Unisphere

Configure initial settings

The Initial Configuration Wizard runs when you log in to Unisphere for the first time.

For the UnityVSA Professional Edition, obtain your license file online using the System UUID.

For the UnityVSA Community Edition, see the Obtaining a license for UnityVSA Community Edition post on the Dell EMC
Community Network website for instructions.

NOTE: Use the License Activation Key instead of the UUID to configure ESRS and obtain support (professional editions).

The Unisphere online help describes the Configuration Wizard and the initial settings you must configure, including pools and
DNS and NTP servers. To create storage resources or NAS servers, you must create at least one pool.

NOTE: You can also create pools on the Unisphere Pools page.

Unisphere scans for the virtual disks available to the UnityVSA VM that can be used in a pool. You add virtual disks to the
UnityVSA VM using vSphere.

When you create a pool, you must specify pool tiering information (Capacity, Performance, Extreme Performance, or NVMe
Extreme Performance). Contact your storage system environment administrator to learn what tier should be assigned to each
virtual disk since the virtualized environment hides this information. If the back-end storage is flash-based, use the Extreme
Performance or NVMe Extreme Performance tier to fully take advantage of the performance capabilities of flash storage. If the
back-end storage is not flash-based, select Performance or Capacity tier to avoid reduced performance.

NOTE: Ensure that you do not assign nonflash-based virtual disks to the Extreme Performance or NVMe Extreme

Performance tier. If you do, high workloads could create too many I/O requests to the backend datastore and consume

excessive bandwidth.

NOTE: Once a disk has been added to a pool, the tier type cannot be changed.

5
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UnityVSA supports the Fully Automated Storage Tiering for Virtual Pool (FAST VP) feature for both block and file data. FAST
VP optimizes storage utilization by automatically moving data between and within the storage tiers.

The maximum space available for all pools is 4 TB, 50 TB, or 350 TB depending on the UnityVSA edition and version. The
maximum number of pools per system is 16. To view your system's limits, select the Settings icon, and then select Software
and Licenses > System Limits.

If your environment uses DHCP, typically the DNS servers are populated automatically. If not, configure the DNS servers.

The accuracy of the time on your UnityVSA server is important to the proper function of UnityVSA. If the time is inconsistent,
features of the UnityVSA that interface with VMWare software or plugins, such as the VMWare VASA provider, may not
function correctly. If you configure NTP, it is recommended that the UnityVSA, ESXi host, and vCenter (if applicable) use the
same NTP server. If you do not configure NTP, UnityVSA gets its time from the ESXi host.

Further configuration

The Unisphere online help describes more configuration procedures and management tasks for your UnityVSA.

Enable or change the tie breaker node on a UnityVSA
HA
If you deployed a UnityVSA HA with a TBN or added a TBN to an existing UnityVSA HA deployment, you must enable it in
Unisphere to make it active. Enable a TBN by using the Unisphere Initial Confguration wizard or the Tie Breaker Node page in
the Unisphere settings.

To enable a TBN using the Tie Breaker Node page:

1. Select the Settings icon, and then select Management > Tie Breaker Node.
2. Select Enable TBN, and select the TBN to enable.

You can also change the active TBN on this page.

You can verify the UUID of the TBN VM in vCenter by browsing to the Virtual Machines tab and locating the VM.

Upgrade tie breaker node after a non-disruptive
upgrade
After performing a non-disruptive upgrade, the tie breaker node must be updated. If you do not upgrade the TBN,
communication between the TBN and SP will fail.

Steps

1. Download both the Unity VSA upgrade package and the new TBN image.

2. From Unisphere, disable the existing TBN:

a. Select the Settings icon, and then select Management > Tie Breaker Node.
b. Clear the checkbox in Enable TBN.

3. From vCenter, power off the TBN:

a. Select the VM of the TBN, then select Power > Power Off.

4. Upgrade Unity VSA.

Refer to the Unisphere Online Help for upgrade instructions.

5. Deploy a new TBN for the upgraded Unity VSA system.

Refer to Deploy a tie breaker node to an existing UnityVSA HA using the GUI.

6. Enable the newly-deployed TBN from Unisphere.

7. Remove the VM of the old TBN from vCenter.
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Appendix: Administrative tasks

Topics:

• Resetting the administrator password

Resetting the administrator password
Follow this procedure to reset the administrator password back to the default.

About this task

This procedure requires a reboot of the SP. If you are resetting the password on a single-SP Unity VSA system, there will be an
outage while the SP is rebooting. Ensure that you schedule a maintenance window for this task.

For Unity VSA HA, only one SP is rebooted, so there is no downtime.

Steps

1. Open the VMware console for the UnityVSA SP VM.

For UnityVSA HA solutions, select either SP.

2. Log in as the service user.

3. Run the following command: svc_shutdown -r
Wait for the SP VM to fully power down.

4. When EMC Boot is displayed, press Tab within three seconds to interrupt the boot process.

5. When the kernel parameters are displayed, append unityvsa_reset_admin_password to the end and press Enter.

Wait for the SP VM to fully power up.

6. After the SP VM is powered on, log in to Unisphere using the default credentials:

● Username: admin
● Password: Password123#

7. Set a new password.
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