A Principled Technologies report: Hands-on testing. Real-world results.

Dell EMC™ ProDeploy set up a
production-ready environment in
less time and fewer steps

Compared to an in-house, entry-level admin, a
Dell Technologies-certified engineer installed
and configured a Dell EMC solution faster and
more efficiently
Adding resources to your data center can help you meet key
business goals quickly. The faster admins can deploy and configure
new hardware, the sooner your critical applications will have access
to resources that could boost revenue streams, expand a customer
base, or promote other positive business outcomes. Choosing
Dell EMC™ ProDeploy to install and configure your new Dell EMC
hardware could allow your organization to feel the impact of new
resources sooner than deploying with in-house, entry-level admins.
In our data center, a Dell Technologies-certified engineer installed
and configured a Dell EMC solution of Dell EMC PowerEdge™ R740
servers, Dell EMC PowerSwitch S4048-ON switches, and a Dell
EMC Unity array in 68 percent less time than our in-house admin
deployed the same solution.
In addition, ProDeploy required little from our in-house
project manager, which allowed them to do other work. A Dell
Technologies-certified engineer deploying Dell EMC hardware in
your data center could mean your IT staff would have more time to
spend on other strategic IT initiatives.
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First things first: Save critical time
by planning deployment with a
Dell Technologies project manager
Project planning can help make even the most complex solution deployment
less frustrating and time consuming. Planning phases give IT teams time to
understand necessary planning processes, read supporting documentation,
and learn toolsets before touching any hardware. Planning a deployment
can (and some might say should) include validating power and connectivity
requirements, determining site readiness, and reviewing best practices.
Without these tasks, organizations could see serious delays and performance
impacts. However, Dell Technologies project managers and engineers from
ProDeploy already know the approaches, tools, and best practices for Dell
EMC solutions.
Before a Dell Technologies engineer did any physical work to deploy the
solution in Figure 1 (for detailed configuration information of the solution, see
the section System configuration information), a Dell Technologies project
manager guided the deployment through the planning phase. They gathered
and documented the project requirements and developed a detailed project
roadmap and implementation plan with our in-house project manager that
highlighted best deployment paths and best practices. Our in-house staff
played a role in only the planning phase of the ProDeploy deployment;
the Dell Technologies-certified engineer handled the hardware unboxing,
racking, and deployment and the Dell Technologies project manager assisted
with planning. Choosing ProDeploy can significantly minimize your IT staff’s
involvement in planning, which allows them to focus on other tasks.
Without ProDeploy, our entry-level admin had to spend time planning the
deployment of the solution in Figure 1. Both deployments (with and without
ProDeploy) needed a project-planning phase, but as Figure 2 shows, the Dell
Technologies project manager saved our IT staff significant time compared to
our entry-level person planning on their own.
Required involvement from entry-level admin
Less time is better

with ProDeploy
1x Dell EMC Unity 650F
all-flash storage

Planning:
2h 35min

Total time:
8h 1min (4x faster)

without ProDeploy (entry-level admin)
Planning:
14h 45min

Figure 1: Illustration of the Dell EMC solution.
Source: Principled Technologies.

Total time:
32h 5min

Figure 2: Time required of an in-house, entry-level admin with and without Dell
EMC ProDeploy service. Source: Principled Technologies.
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A ProDeploy engineer needed less time than our entry-level admin
For the ProDeploy deployment, our entry-level admin spent 2 hours and 35 minutes planning the deployment with
a Dell Technologies project manager before the Dell Technologies-certified engineer arrived at our datacenter.
Those 2 hours and 35 minutes completed our involvement; we did not need to be involved in any further planning
or deployment. Over the course of two business days, the Dell Technologies-certified engineer spent 5 hours
and 26 minutes physically installing and configuring the PowerEdge servers, networking components, Unity array,
and software.
Without ProDeploy, we spent 32 hours and 5 minutes installing and configuring the solution over six business days.
Figure 3 breaks down deployment in business days. Highlights include the following:
• With ProDeploy, unboxing and racking the PowerEdge servers, networking components, and the Unity array
took 83 percent less time and saved 2 hours and 9 minutes compared to the time it took our in-house, entrylevel admin. ProDeploy saved 2 hours and 45 minutes when cabling the solution.
• Setting up the networking components with ProDeploy saved nearly 1 hour and 58 minutes and took 85
percent less time.
• Following deployment best practices took
longer for our entry-level admin because
they required deployment documentation
for guidance.
• With ProDeploy, configuring the Dell EMC
Unity array, upgrading its firmware and
software, and performing a health check on
the array saved 1 hour and 3 minutes and
took 42 percent less time.
• With ProDeploy, installing the OS, updating
the server firmware, setting up VMware
vCenter®, and updating VMware ESXi™ saved
a sizable chunk of time—almost 4 hours—and
took 60 percent less time.

Time spent on deployment each day
Less time is better

ProDeploy engineer
Mon

8h 1min (4x faster)
Tues

Entry-level admin
Mon

32h 5min
Tues

Wed

Thurs

Fri

Mon

Figure 3: Comparison of time required to complete server deployment
for a Dell Technologies-certified engineer and an in-house, entry-level
admin. Source: Principled Technologies.

Table 1 breaks down the deployment times by stage of installation and configuration in hours and minutes.
Table 1: Comparison of time (in hours:minutes) required to complete each stage of the deployment process for an in-house,
entry-level admin and a Dell Technologies-certified engineer. Source: Principled Technologies.
Stage

Entry-level admin

Planning

ProDeploy engineer

ProDeploy
percentage less time

14:45

2:35

82%

Racking hardware & cabling

5:55

1:01

82%

Configuring networking

2:18

0:20

85%

Configuring OS & firmware

6:38

2:39

60%

Configuring storage

2:29

1:26

42%

Total deployment time without planning stage

17:20

5:26

68%

Total planning and deployment time

32:05

8:01

75%
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Day-by-day breakdown:
ProDeploy vs. in-house deployment
Table 2 shows how our in-house admin and the Dell Technologies-certified engineer spent their
time on the first day. Without ProDeploy, we spent the first 4 hours confirming implementation
details with our in-house project manager. It took the Dell Technologies-certified engineer 1 hour
and 38 fewer minutes to plan the deployment; unbox, rack, and cable the solution; conduct a health
check; update the server firmware; install the OS; configure the Ethernet switch; set up vCenter; and
update ESXi than it took us to plan this first day and unbox, rack, and cable the PowerEdge servers,
networking components, and Unity array.
Table 2: Comparison between an in-house, entry-level admin and a Dell Technologies-certified engineer for
time (in hours:minutes) required to deploy the solution during day one. Source: Principled Technologies.
Stage

Entry-level admin

ProDeploy engineer

Planning

4:00

2:35

Unboxing and racking

2:35

0:26

Initial cabling

1:15

0:35

Checking server health

0:25

Updating server firmware

0:28

OS installation

0:12

Ethernet switch config

0:20

vCenter setup

0:21

ESXi updates

0:50

Time spent deploying the Dell EMC solution

7:50

6:12

Table 3 shows how our admin without ProDeploy and the Dell Technologies-certified engineer
spent their time on the second day. In addition to the deployment, our admin had to address
unrelated administrative and routine tasks that needed immediate attention. The Dell
Technologies-certified engineer, however, was able to focus and complete the deployment.
Table 3: Comparison between an in-house, entry-level admin and a Dell Technologies-certified engineer for
time (in hours:minutes) required to deploy the solution during day two. Source: Principled Technologies.
Stage

Entry-level admin

Planning

1:15

Initial cabling

2:05

ProDeploy engineer

Storage configuration

0:23

Storage firmware/software upgrade

0:38

**Installation of OME and SAE

0:48

Time spent deploying the Dell EMC solution
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It took our in-house, entry-level admin four more business days to finish planning the installation as
well as to finish installing and configuring the new PowerEdge servers, networking components, and
Unity arrays from Dell EMC. That’s six business days total, compared to the two business days it took
the Dell Technologies-certified engineer. An organization would have had the new PowerEdge servers,
networking components, and Unity array up and running six days earlier (including Saturday and
Sunday) by using ProDeploy. After two days, our admin still had a lot to do, as Table 4 shows.
Table 4: Breakdown of in-house, entry-level admin time (in hours:minutes) on the remaining days.
Source: Principled Technologies.
Stage

Entry-level admin

ProDeploy engineer

(Day 3) Wednesday
Planning

3:00

Time spent deploying the Dell EMC solution

3:00

0:00

(Day 4) Thursday
Planning

3:45

Health check

0:30

Time spent deploying the Dell EMC solution

4:15

0:00

(Day 5) Friday
Planning

1:15

Configuring storage

0:42

Upgrading storage firmware

1:17

Server firmware update

0:42

OS installation

0:27

Ethernet switch config

0:53

ESXi updates

0:36

Time spent deploying the Dell EMC solution

5:52

0:00

(Day 6) Monday
Planning

1:30

Ethernet switch config

1:25

vCenter setup

0:48

ESXi updates

1:00

Installing OME and SAE

3:05

Time spent deploying the Dell EMC solution

7:48
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Get additional post-deployment care from Dell Technologies
After installing and configuring the solution, our in-house admin and the Dell Technologies-certified engineer
initiated post-deployment services. These were mostly checks to ensure things were running smoothly. However,
the Dell Technologies-certified engineer took some extra time to do things beyond deployment. In addition to
collecting environment configuration across all the platforms, they performed a final health check, validated that
they had implemented all configuration best practices, and completed the remaining documentation.

Compliance with
COVID-19 restrictions
Before the Dell Technologies engineer
visited our data center, we informed
them of our social distancing policy
and face covering requirement to
help reduce the potential spread of
the virus causing coronavirus disease
2019 (COVID-19). The engineer
complied by maintaining a distance
of at least six feet from others and
by wearing a mask that covered their
mouth and nose at all times.

Conclusion
Choosing ProDeploy to install and configure new Dell EMC hardware means your organization can get new
data center resources to applications more quickly without tying up too much of an admin’s time. In our
data center:
• The Dell Technologies-certified engineer installed and configured the Dell EMC solution in 68 percent less
time, saving 11 hours and 54 minutes and allowing our in-house admin to focus on organizational demands
and other strategic initiatives.
• Installing and configuring the Dell EMC solution with ProDeploy reduced the total planning and
deployment time by 75 percent, 4 times faster than our in-house admin.
• The Dell Technologies-certified engineer needed only 5 hours and 26 minutes over two business days to
deploy the Dell EMC solution.
• Without ProDeploy, it took more than 17 hours over six business days for our in-house, entry-level admin to
install and configure the same solution.
• Familiarity with the solution components allowed the Dell Technologies-certified engineer to complete
tasks, such as configuring the network, faster than our in-house, entry-level admin, who sometimes needed
documentation and guidance from our project manager.
With ProDeploy, your organization can realize a faster, more efficient deployment with minimal impact on your
in-house IT staff.
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We concluded our hands-on testing on July 7, 2020. During testing, we determined the appropriate hardware
and software configurations and applied updates as they became available. The results in this report reflect
configurations that we finalized on June 23, 2020 or earlier. Unavoidably, these configurations may not represent
the latest versions available when this report appears.

Our results
For our calculations, we found that the Dell EMC ProDeploy time of 8 hours and 1 minute was just under a
quarter of the in-house, entry level time of 32 hours and 5 minutes. Therefore, we assume that a Dell EMC
ProDeploy-certified engineer could do four deployments in the time of one in-house, entry level IT adminconducted deployment and thus is four times faster.
Table 5: Times (in hours:minutes) for each stage of deployment.
Task

In-house, entry-level IT admin

Planning

Dell EMC ProDeploy-certified engineer
14:45

2:35

Unboxing and racking

2:35

0:26

Initial cabling

3:20

0:35

Storage configuration

0:42

0:23

Storage firmware/software upgrade

1:17

0:38

Health check

0:30

0:25

Server firmware update

0:42

0:28

OS installation

0:27

0:12

Ethernet switch config

2:18

0:20

vCenter setup

0:48

0:21

ESXi updates

1:36

0:50

Installation of OME and SAE

3:05

0:48

32:05

8:01

Total time
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System configuration information
Table 6: Detailed information for the deployed servers. Source: Principled Technologies.
Server configuration information

Dell EMC PowerEdge R740

BIOS name and version

2.6.4

Non-default BIOS settings

none

Operating system name and version/build number

VMware ESXi™ 7.0 15843807

Date of last OS updates/patches applied

6/22/20

Power management policy

Balanced

Processor
Number of processors

2

Vendor and model

Intel® Xeon® Silver 4216

Core count (per processor)

16

Core frequency (GHz)

2.1

Stepping

7

Memory module(s)
Total memory in system (GB)

96
Memory module A

Memory module B

Number of memory modules

2

2

Vendor and model

Samsung® M393A2K43BB1-CTD6Q

Samsung M393A4K40CB2-CTD7Q

Size (GB)

16

32

Type

DDR4

DDR4

Speed (MHz)

2,666

2,666

Speed running in the server (MHz)

2,666

2,666

Storage controller
Vendor and model

Dell PERC H740P Mini

Cache size (GB)

4

Firmware version

50.9.4-3025

Driver version

7.712.50.00

Local storage (type A)
Number of drives

2

Drive vendor and model

Micron® MTFDDAK480TDN

Drive size (GB)

480

Drive information (speed, interface, type)

6GB/s, SAS, SSD
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Server configuration information

Dell EMC PowerEdge R740

Local storage (type B)
Number of drives

1

Drive vendor and model

Seagate ST600MM0069

Drive size (GB)

600

Drive information (speed, interface, type)

12GB/s, SAS, HDD

Network adapter (type A)
Vendor and model

Broadcom Adv. Dual 10GBASE-T Ethernet

Number and type of ports

4

Driver version

21.60.22.11

Network adapter (type B)
Vendor and model

Intel Ethernet Server Adapter X520

Number and type of ports

2

Driver version

1.7.1.26

Cooling fans
Vendor and model

Nidec Ultraflo XN44V-A00

Number of cooling fans

6

Power supplies
Vendor and model

Dell PWR SPLY, 750W

Number of power supplies

2

Wattage of each (W)

750

Table 7: Detailed information for the deployed storage. Source: Principled Technologies.
Storage configuration information

Dell EMC Unity 650F

Software Version

5.0.3.0.5.014

Number of drives

10

Drive vendor and model

Samsung MZ-ILT1T9A

Drive size

1.92TB

Protocol

SAS

Gb/s

12Gb/s
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Table 8: Detailed information for the deployed switches. Source: Principled Technologies.
Switch configuration information

Dell EMC PowerConnect 5448

Port type A
Type of ports

Gigabit ethernet

Number of ports

48

Port type B
Type of ports

Combo gigabit SFP

Number of ports

4
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How we tested
Configuring Unity 650F
1.
2.
3.
4.
5.
6.
7.

Visit https://www.dell.com/support/home/en-us/product-support/product/unity-family/overview, and download the Dell EMC Unity
Connection Utility.
When the download is finished, click Run.
At the Select Setup Language screen, Select English, and click OK.
At the Welcome screen, click Next.
At the Choose Install Folder, accept defaults, and click Next.
At the Pre-Installation Summary screen, click Install.
Check Run Connection Utility, and click Finish.

Connecting to the storage and configuring management IP address
1.
2.
3.
4.
5.

In the connection utility, select Auto Discover, and click Next.
Select the System, and click Next.
Enter the management IP information, and click Next.
Review the information, and click Next.
Click Deploy.

Running the initial configuration wizard
1.
2.
3.
4.
5.
6.
7.

At the introduction screen, click Next.
Enter the DNS server address, and click Next.
At the NTP server screen, click Add.
Enter the NTP server IP, and click Next.
Apply the Unisphere License, and click Next.
Until the initial configuration wizard completes, click Next.
Check Run Connection Utility, and click Finish.

Creating a storage pool
1.
2.
3.
4.
5.
6.
7.

On left Unisphere pane, under Storage, click Pools.
Click +.
Enter a Pool name and description.
Select Extreme Performance Tier, and click Next.
Select all available drives, and click Next.
At the Capability Profile Name screen, click Next.
At the Summary screen, click Finish.

Creating a NAS server
1.
2.
3.
4.
5.
6.
7.
8.
9.

Under Storage, select File>NAS Servers.
Click the add icon.
Create a server name, and choose the appropriate pool and storage processor.
Click Next.
Select the Ethernet port, and set the IP address, subnet mask, and Gateway.
Click Next.
Check Enable NFSv3 and NFSv4.
On DNS, Replication, and Summary, click Next.
Click Finish.
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Creating a file system
1.
2.
3.
4.
5.
6.
7.
8.

Under Storage, select File>File Systems.
Click the add icon.
Create a name and description.
Click Next.
On File-level Retention, click Next.
Select the appropriate pool, set its size, and check Thin.
On subsequent screens, check Next.
Click Finish.

Discovering and adding multiple ESXi hosts
1.
2.
3.
4.
5.
6.

On left Unisphere pane, under Access, click VMware.
To connect to the vCenter server, click +.
At the Find ESXi Hosts screen, enter the vCenter credentials, and click Find.
Select the appropriate ESXi hosts, and click Next.
At the VSA Provider screen, click Next.
At the Summary screen, click Finish.

Installing VMware ESXi
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.

Using the USB, boot to the VMware ESXi installation media.
To Continue, press Enter.
To Accept and Continue, press F11 key.
Under Storage Device, select the installation drive, and press Enter.
For keyboard layout, select US Default, and press Enter.
Enter the root password twice, and press Enter.
At the Confirm Install window, press F11.
At the Installation Complete window, press Enter.
To configure the system after rebooting, press F2.
Log in with root credentials, and press Enter.
Scroll to Configure Management Network, and press Enter.
Scroll to IPv4 Configuration, and press Enter.
Scroll to Static IPv4, and use the spacebar to select it.
Set the IPv4 address, Subnet Mask, and Default gateway.
Press Enter.
Scroll to IPv6 Configuration, and press Enter.
Scroll to Disable IPv6, and use the spacebar to select it.
Press Enter.
Scroll to DNS Configuration, and press Enter.
Scroll to manually configure DNS, and use the spacebar to select it.
Add the Primary DNS Server and the Alternate DNS Server, and provide the hostname for the system.
Scroll to Custom DNS Suffixes, and press Enter.
Add the suffix that is required for testing, and press Enter.
To accept the changes, press Esc.
To confirm changes, press Y. The system will reboot.
To configure the system after rebooting, press F2.
Log in with root credentials, and press Enter.
Scroll to Troubleshooting Options, and press Enter.
Select Enable ESXi Shell, and press Enter.
Select Enable SSH, and press Enter.
Scroll to Restart Management Agents, and press Enter.
Press F11.
To exit, press Esc.
To log out, press Esc.
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Deploying VMware vCenter Server® 7.0
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.

Using a USB drive, on a Windows server or VM, locate the VMware-VCSA installer image using USB.
Mount the image, navigate to the vcsa-ui-installer folder, and double-click win32.
Double-click installer.exe.
Click Install.
Click Next.
Accept the terms of the license agreement, and click Next.
Ensure that the vCenter Server with an Embedded Platform Services Controller is selected, and click Next.
Enter the FQDN or IP address of the host onto which you are deploying the vCenter Server Appliance.
Provide the server’s username and password, and click Next.
To accept the certificate of the host you chose to connect to, click Yes.
Provide a name and password for the vCenter Appliance, and click Next.
Set an appropriate appliance size, and click Next.
Select the appropriate datastore, and click Next.
At the Configure Network Settings page, configure the network settings as appropriate for your environment, and click Next.
Review your settings, and click Finish.
When the deployment completes, click Continue.
At the Introduction page, click Next.
At the Appliance configuration page, select the time synchronization mode and SSH access settings, and click Next.
At the CEIP page, click Next.
At the Ready to complete page, click Finish.
At the Warning pop-up, click OK.
Once Stage 2 completes successfully, click Close.

Adding the servers to vCenter
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.

Log into vCenter.
In the left pane, right-click vCenter, and select New Datacenter.
Enter the name of your datacenter, and press OK.
Right-click your datacenter, and select Add Host.
In Name and location, add the IP address of your host, and click Next.
In Connection settings, to log into your ESXi host, enter the username and password, and click Next.
In Host summary, verify your host’s information, and click Next.
In Assign license, choose the appropriate license for your host, and click Next.
In Lockdown mode, leave the host lockdown as default (Disabled), and click Next.
In VM location, choose the location where your VMs will be organized, and click Next.
In Ready to complete, verify your settings, and click Finish.
Complete steps 4 through 11 for the remaining three servers.

Downloading and installing OpenManage Enterprise
1.

From the support site, download the openmanage_enterprise_ovf_format.zip file, and extract the file to a location accessible by the
VMware vSphere Client.
2. In vSphere Client, select File>Deploy OVF Template.
3. On the Local file option, click Upload files, select the OVF and VMDK packages, and click Next.
4. Name the VM, select the Datacenter, and click Next.
5. Select the host on which you want to deploy the appliance VM, and click Next.
6. Review the details, and click Next.
7. Accept the License agreements, and click Next.
8. Select storage option, choose Thin provision, and click Next.
9. Select Networks, and click Next.
10. Enter DNS, hostname, Gateway, network address (IPV4), time zone, NTP server address, and click next.
11. Review the settings, and click Finish.
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Configuring OpenManage Enterprise
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

In a web browser, navigate to the IP of the OpenManage Enterprise VM, and log in.
On the Home tab, choose Discover Devices.
Click Add, and in the Device Type dropdown, choose Server.
Select Dell iDRAC, and click OK.
In the IP/Hostname/Range box, enter the IP range of the servers.
For the servers, enter the login credentials.
Select Run Now, and click Finish.
For the virtual machine files, select the datastore, and click Next.
On the Disk Format page, to pre-allocate physical storage space to VMs, click Thick provision.
Review the selected options, and click Finish.

Downloading and installing SupportAssist Enterprise
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.

From the support site, download the OVF file, and extract the file to a location accessible by the VMware vSphere Client.
In vSphere Client, select File>Deploy OVF Template.
On the local file option, click Upload files, select the OVF and VMDK packages, and click Next.
Name the VM, select the Datacenter, and click Next.
Select the host on which you want to deploy the appliance VM, and click Next.
Review the details, and click Next.
Accept the license agreements, and click Next.
Select storage option, choose Thin provision, and click Next.
Select the networks, and click Next.
Enter DNS, hostname, Gateway, network address (IPV4), time zone, NTP server address, and click Next.
Review the settings, and click Finish.

Configuring SupportAssist Enterprise
1.
2.
3.
4.
5.
6.

In a web browser, navigate to the IP of the SupportAssist Enterprise VM, and log in.
On the Devices tab, choose Add.
In Device Type, select iDRAC, enter the IP address of the host, name the host, and choose create new credentials account.
Name the credentials, and select the device type, operating system, username, and password. Click Save.
Select the account credentials you created, and select Next.
For the additional three servers, complete steps 1 through 5.
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